Page 1 of 1

Opel Tigra SWC Not working

Posted: Wed Sep 12, 2018 9:27 am
by Lee
Hi I recently purchased a Pumpkin 7.1 car radio monireciever sept 2nd 2018 ORDER NUMBER 303-2327561-0927513

I have an 2007 Opel Tigra Twintop 1.4l

The unit works however the steering wheel controls do not. I have set the Car setting to OPEL via the menu.

I have noticed when I adjust the volume up and down or change the channel on the radio the small orange factory car screen changes as well. This would suggest to me that the stereo is connected

When I try to use any of the steering wheel buttons or register any of the buttons it does no recognise I am pressing them.

Do I need to connect the [ Key 1 ] or [ Key 2 ] wires, I thought with the can bus adapter supplied this is not necessary.

Please let me know what my next step should be, I am stuck as to where to go next? Is the can bus adapter faulty, does it not work with my car?

I have attached a picture of my car with the stereo connected.

Opel.jpg
Opel Tigra
Opel.jpg (838.53 KiB) Viewed 275 times


Any help would be greatly appreciated
Kind Regards
Lee

Re: Opel Tigra SWC Not working

Posted: Thu Sep 13, 2018 2:08 am
by Jammy
Hi, could you show me the diagram of your original car connectors ? And which swc buttons don't work ?
Could you mind show me an short video about all your query ? it is direct and helpful for us to find the cause .
At last , which power cable were you using ?
Regards

Re: Opel Tigra SWC Not working

Posted: Thu Sep 13, 2018 9:08 pm
by Lee
None of the steering wheel controls work. I can make a video and demonstrate the buttons etc. I will also take pictures of the connections, etc and post them tomorrow so you have all the information needed thank you.

At the moment it is 11:06pm and I have to get up to work at 4:30am so it will have to be after I get home. Then I will post all that you have requested

Kind Regards
Lee

Re: Opel Tigra SWC Not working

Posted: Fri Sep 14, 2018 4:35 am
by Lee
When i get home today i can supply all the information you require :)

Re: Opel Tigra SWC Not working

Posted: Fri Sep 14, 2018 7:15 pm
by Lee
As requested please find attached a Video of the problem that I have, Also a number of pictures showing the original Stereo, the connection diagram from the original stereo, the wiring loom you supplied that I used, the can bus adapter that was supplied, and the wiring that I have used so far

Please advise how I get the SWC buttons to work as the rest seems to work fine

The Youtube link for my video is here:

https://www.youtube.com/watch?v=yYWB728 ... e=youtu.be

Kind Regards
Lee

Re: Opel Tigra SWC Not working

Posted: Tue Sep 18, 2018 3:32 am
by Jammy
Hi,
thanks for your video and pictures. They are very helpful .
About this issue, i suggest you purchase this kind of adapter .https://www.amazon.de/ctsvx002-2-Vauxha ... ll+CAN-Bus
You can refer to this article .
viewtopic.php?f=13&t=10451&start=20
Regards